<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role As Superman</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%2C300%7CRoboto%3A400%2C500%2C700%2C300&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%2C300%7CRoboto%3A400%2C500%2C700%2C300&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open%20Sans%3A400%2C600%2C700%2C300%7CRoboto%3A400%2C500%2C700%2C300&#038;display=swap" /></noscript><link rel="stylesheet" href="https://alphanewscall.com/wp-content/cache/min/1/e9bfda37fc115667911f500722c42e00.css" media="all" data-minify="1" />
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://alphanewscall.com/xmlrpc.php" />
<script type="text/javascript">
!function(){var e={};e.g=function(){if("object"==typeof globalThis)return globalThis;try{return this||new Function("return this")()}catch(e){if("object"==typeof window)return window}}(),function(n){let{ampUrl:t,isCustomizePreview:r,isAmpDevMode:o,noampQueryVarName:s,noampQueryVarValue:i,disabledStorageKey:a,mobileUserAgents:c,regexRegex:u}=n;if("undefined"==typeof sessionStorage)return;const d=new RegExp(u);if(!c.some((e=>{const n=e.match(d);return!(!n||!new RegExp(n[1],n[2]).test(navigator.userAgent))||navigator.userAgent.includes(e)})))return;e.g.addEventListener("DOMContentLoaded",(()=>{const e=document.getElementById("amp-mobile-version-switcher");if(!e)return;e.hidden=!1;const n=e.querySelector("a[href]");n&&n.addEventListener("click",(()=>{sessionStorage.removeItem(a)}))}));const g=o&&["paired-browsing-non-amp","paired-browsing-amp"].includes(window.name);if(sessionStorage.getItem(a)||r||g)return;const m=new URL(location.href),h=new URL(t);h.hash=m.hash,m.searchParams.has(s)&&i===m.searchParams.get(s)?sessionStorage.setItem(a,"1"):h.href!==m.href&&(window.stop(),location.replace(h.href))}({"ampUrl":"https:\/\/alphanewscall.com\/2022\/05\/24\/man-steel-2-release\/amp\/","noampQueryVarName":"noamp","noampQueryVarValue":"mobile","disabledStorageKey":"amp_mobile_redirect_disabled","mobileUserAgents":["Mobile","Android","Silk\/","Kindle","BlackBerry","Opera Mini","Opera Mobi"],"regexRegex":"^\\/((?:.|\n)+)\\/([i]*)$","isCustomizePreview":false,"isAmpDevMode":false})}();
</script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://alphanewscall.com/wp-content/uploads/2022/05/cropped-Alpha-News-Call-Icon-300x300-1-300x300.png">

<meta name="description" content="The DC Comics superhero film will entertain you in 2022. Furthermore, the probable release date is somewhere in November." />
<link rel="canonical" href="https://alphanewscall.com/2022/05/24/man-steel-2-release/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role As Superman" />
<meta property="og:description" content="The DC Comics superhero film will entertain you in 2022. Furthermore, the probable release date is somewhere in November." />
<meta property="og:url" content="https://alphanewscall.com/2022/05/24/man-steel-2-release/" />
<meta property="og:site_name" content="AlphaNewsCall" />
<meta property="article:published_time" content="2022-05-24T10:14:06+00:00" />
<meta property="article:modified_time" content="2022-05-24T10:16:33+00:00" />
<meta property="og:image" content="https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="400" />
<meta property="og:image:type" content="image/png" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="AlphaNewscallAuthor" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="4 minutes" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://alphanewscall.com/#website","url":"https://alphanewscall.com/","name":"AlphaNewsCall","description":"Trending News","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://alphanewscall.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://alphanewscall.com/2022/05/24/man-steel-2-release/#primaryimage","url":"https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png","contentUrl":"https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png","width":800,"height":400,"caption":"Henry Cavill Will Reprise His Role As Superman In Man Of Steel 2"},{"@type":"WebPage","@id":"https://alphanewscall.com/2022/05/24/man-steel-2-release/#webpage","url":"https://alphanewscall.com/2022/05/24/man-steel-2-release/","name":"Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role As Superman","isPartOf":{"@id":"https://alphanewscall.com/#website"},"primaryImageOfPage":{"@id":"https://alphanewscall.com/2022/05/24/man-steel-2-release/#primaryimage"},"datePublished":"2022-05-24T10:14:06+00:00","dateModified":"2022-05-24T10:16:33+00:00","author":{"@id":"https://alphanewscall.com/#/schema/person/b45abe9af05df5d2bd7e0c7fbcb27d2f"},"description":"The DC Comics superhero film will entertain you in 2022. Furthermore, the probable release date is somewhere in November.","breadcrumb":{"@id":"https://alphanewscall.com/2022/05/24/man-steel-2-release/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://alphanewscall.com/2022/05/24/man-steel-2-release/"]}]},{"@type":"BreadcrumbList","@id":"https://alphanewscall.com/2022/05/24/man-steel-2-release/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://alphanewscall.com/"},{"@type":"ListItem","position":2,"name":"Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role As Superman"}]},{"@type":"Person","@id":"https://alphanewscall.com/#/schema/person/b45abe9af05df5d2bd7e0c7fbcb27d2f","name":"AlphaNewscallAuthor","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://alphanewscall.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/7ceaf5b124e5c46d90bb283eb64c0f95?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/7ceaf5b124e5c46d90bb283eb64c0f95?s=96&d=mm&r=g","caption":"AlphaNewscallAuthor"},"url":"https://alphanewscall.com/author/alphanewscallauthor/"}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="AlphaNewsCall &raquo; Feed" href="https://alphanewscall.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="AlphaNewsCall &raquo; Comments Feed" href="https://alphanewscall.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="AlphaNewsCall &raquo; Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role As Superman Comments Feed" href="https://alphanewscall.com/2022/05/24/man-steel-2-release/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style id='global-styles-inline-css' type='text/css'>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</style>
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel="https://api.w.org/" href="https://alphanewscall.com/wp-json/" /><link rel="alternate" type="application/json" href="https://alphanewscall.com/wp-json/wp/v2/posts/141432" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://alphanewscall.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://alphanewscall.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.3" />
<link rel='shortlink' href='https://alphanewscall.com/?p=141432' />
<link rel="alternate" type="application/json+oembed" href="https://alphanewscall.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falphanewscall.com%2F2022%2F05%2F24%2Fman-steel-2-release%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://alphanewscall.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falphanewscall.com%2F2022%2F05%2F24%2Fman-steel-2-release%2F&#038;format=xml" />

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-205882741-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-205882741-1');
</script>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5923199195091205" crossorigin="anonymous"></script><!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"8243eebc83","wpRestUrl":"https:\/\/alphanewscall.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","globalSettings":{"tdcSavingHistory":false},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":20,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<style id="tdb-global-colors">
        :root {--accent-color: #fff;--downtown-accent: #EDB500;--downtown-accent-light: #ffd13a;--downtown-accent-titles: #444444;--downtown-menu-bg: #01175e;--downtown-menu-bg-light: #0a2472;}
    </style>
<style id="tdb-global-fonts">
        :root {--downtown-serif-font: Zilla Slab;--downtown-sans-serif-font: Red Hat Display;}
    </style>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/alphanewscall.com\/wp-admin\/","wpRestNonce":"8243eebc83","wpRestUrl":"https:\/\/alphanewscall.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
<script>
        window.tdaGlobal = {"adminUrl":"https:\/\/alphanewscall.com\/wp-admin\/","wpRestNonce":"8243eebc83","wpRestUrl":"https:\/\/alphanewscall.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","postId":141432};
    </script>
<link rel="amphtml" href="https://alphanewscall.com/2022/05/24/man-steel-2-release/amp/"><style>#amp-mobile-version-switcher{left:0;position:absolute;width:100%;z-index:100}#amp-mobile-version-switcher>a{background-color:#444;border:0;color:#eaeaea;display:block;font-family:-apple-system,BlinkMacSystemFont,Segoe UI,Roboto,Oxygen-Sans,Ubuntu,Cantarell,Helvetica Neue,sans-serif;font-size:16px;font-weight:600;padding:15px 0;text-align:center;text-decoration:none}#amp-mobile-version-switcher>a:active,#amp-mobile-version-switcher>a:focus,#amp-mobile-version-switcher>a:hover{text-decoration:underline}</style><link rel="alternate" type="text/html" media="only screen and (max-width: 640px)" href="https://alphanewscall.com/2022/05/24/man-steel-2-release/amp/">

<script>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</script>

<style>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</style>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://alphanewscall.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://alphanewscall.com/category/entertainment/",
                    "name": "Entertainment"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://alphanewscall.com/2022/05/24/man-steel-2-release/",
                    "name": "Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role..."                                
                }
            }    
        ]
    }
</script>

<style>
    
</style>
<style id="tdw-css-placeholder"></style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>
<body class="post-template-default single single-post postid-141432 single-format-standard td-standard-pack man-steel-2-release global-block-template-1 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background" style="visibility:hidden"></div>
<div id="td-mobile-nav" style="visibility:hidden">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
</div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>

<div class="td-menu-login-section">
<div class="td-guest-wrap">
<div class="td-menu-login"><a id="login-link-mob">Sign in</a></div>
</div>
</div>

<div class="td-mobile-content">
<div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-139490" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first menu-item-139490"><a href="https://alphanewscall.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-139491" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139491"><a href="https://alphanewscall.com/category/celebrity/">Celebrity</a></li>
<li id="menu-item-139541" class="menu-item menu-item-type- menu-item-object- menu-item-139541"><a></a></li>
<li id="menu-item-139492" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139492"><a href="https://alphanewscall.com/category/top-stories/">Top Stories</a></li>
<li id="menu-item-139542" class="menu-item menu-item-type- menu-item-object-category menu-item-139542"><a>Celebrity</a></li>
<li id="menu-item-139493" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139493"><a href="https://alphanewscall.com/category/reviews/">Reviews</a></li>
<li id="menu-item-139543" class="menu-item menu-item-type- menu-item-object- menu-item-139543"><a></a></li>
<li id="menu-item-139494" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139494"><a href="https://alphanewscall.com/category/trending/">Trending</a></li>
<li id="menu-item-139544" class="menu-item menu-item-type- menu-item-object- menu-item-139544"><a></a></li>
<li id="menu-item-139495" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139495"><a href="https://alphanewscall.com/category/feature/">Feature</a></li>
<li id="menu-item-139545" class="menu-item menu-item-type- menu-item-object-category menu-item-139545"><a></a></li>
<li id="menu-item-139496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139496"><a href="https://alphanewscall.com/category/world/">World</a></li>
<li id="menu-item-139546" class="menu-item menu-item-type- menu-item-object- menu-item-139546"><a></a></li>
</ul></div> </div>
</div>

<div id="login-form-mobile" class="td-register-section">
<div id="td-login-mob" class="td-login-animation td-login-hide-mob">

<div class="td-login-close">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Sign in</div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>
<form class="td-login-form-wrap" action="#" method="post">
<div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email-mob" value="" required><label for="login_email-mob">your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass-mob" value="" required><label for="login_pass-mob">your password</label></div>
<input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
<div class="td-login-info-text">
<a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
</div>
<div class="td-login-register-link">
</div>
</form>
</div>
<div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">

<div class="td-forgot-pass-close">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-read-down"></i></a>
<div class="td-login-title">Password recovery</div>
</div>
<div class="td-login-form-wrap">
<div class="td-login-panel-title">Recover your password</div>
<div class="td_display_err"></div>
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label for="forgot_email-mob">your email</label></div>
<input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
</div>
</div>
</div>
</div> <div class="td-search-background" style="visibility:hidden"></div>
<div class="td-search-wrap-mob" style="visibility:hidden">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://alphanewscall.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-5 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim td-login-modal-wrap">
<div class="td-login-wrap">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<form id="loginForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
</form>
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
 <form id="forgotpassForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
</form>
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap ">
<div class="td-container td-header-row td-header-main-menu black-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-menu">
<a class="td-main-logo" href="https://alphanewscall.com/">
<img width="300" height="75" class="td-retina-data" data-retina="https://alphanewscall.com/wp-content/uploads/2021/08/cropped-Alpha-News-Call-Icon-300x300.png" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%2075'%3E%3C/svg%3E" alt="" data-lazy-src="https://alphanewscall.com/wp-content/uploads/2021/08/Alpha-News-Call-4-300x75.png" /><noscript><img width="300" height="75" class="td-retina-data" data-retina="https://alphanewscall.com/wp-content/uploads/2021/08/cropped-Alpha-News-Call-Icon-300x300.png" src="https://alphanewscall.com/wp-content/uploads/2021/08/Alpha-News-Call-4-300x75.png" alt=""/></noscript>
<span class="td-visual-hidden">AlphaNewsCall</span>
</a>
</div>
<div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-first td-menu-item td-normal-menu menu-item-139490"><a href="https://alphanewscall.com/category/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-139491"><a href="https://alphanewscall.com/category/celebrity/">Celebrity</a></li>
<li class="menu-item menu-item-type- menu-item-object- td-menu-item td-normal-menu menu-item-139541"><a></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-139492"><a href="https://alphanewscall.com/category/top-stories/">Top Stories</a></li>
<li class="menu-item menu-item-type- menu-item-object-category td-menu-item td-normal-menu menu-item-139542"><a>Celebrity</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-139493"><a href="https://alphanewscall.com/category/reviews/">Reviews</a></li>
<li class="menu-item menu-item-type- menu-item-object- td-menu-item td-normal-menu menu-item-139543"><a></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-139494"><a href="https://alphanewscall.com/category/trending/">Trending</a></li>
<li class="menu-item menu-item-type- menu-item-object- td-menu-item td-normal-menu menu-item-139544"><a></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-139495"><a href="https://alphanewscall.com/category/feature/">Feature</a></li>
<li class="menu-item menu-item-type- menu-item-object-category td-menu-item td-normal-menu menu-item-139545"><a></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-139496"><a href="https://alphanewscall.com/category/world/">World</a></li>
<li class="menu-item menu-item-type- menu-item-object- td-menu-item td-normal-menu menu-item-139546"><a></a></li>
</ul></div></div>
<div class="header-search-wrap">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://alphanewscall.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://alphanewscall.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Entertainment" class="entry-crumb" href="https://alphanewscall.com/category/entertainment/">Entertainment</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role...</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5923199195091205" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5923199195091205" data-ad-slot="5927548321" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<article id="post-141432" class="post-141432 post type-post status-publish format-standard has-post-thumbnail category-entertainment tag-movie tag-top-trending" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">
<ul class="td-category"><li class="entry-category"><a href="https://alphanewscall.com/category/entertainment/">Entertainment</a></li></ul>
<header class="td-post-title">
<h1 class="entry-title">Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role As Superman</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://alphanewscall.com/author/alphanewscallauthor/">AlphaNewscallAuthor</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-05-24T10:14:06+00:00">May 24, 2022</time></span> <div class="td-post-comments"><a href="https://alphanewscall.com/2022/05/24/man-steel-2-release/?noamp=mobile#respond"><i class="td-icon-comments"></i>0</a></div> <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-141432">28</span></div> </div>
</header>

</div>
<div class="td-post-sharing-top"><div id="td_social_sharing_article_top" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
<style>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</style>
<div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Falphanewscall.com%2F2022%2F05%2F24%2Fman-steel-2-release%2F" title="Facebook"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Man+Of+Steel+2+Release+Date%3A+Henry+Cavill+Will+Reprise+His+Role+As+Superman&url=https%3A%2F%2Falphanewscall.com%2F2022%2F05%2F24%2Fman-steel-2-release%2F&via=AlphaNewsCall" title="Twitter"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://alphanewscall.com/2022/05/24/man-steel-2-release/&amp;media=https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png&description=The DC Comics superhero film will entertain you in 2022. Furthermore, the probable release date is somewhere in November." title="Pinterest"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Man+Of+Steel+2+Release+Date%3A+Henry+Cavill+Will+Reprise+His+Role+As+Superman %0A%0A https://alphanewscall.com/2022/05/24/man-steel-2-release/" title="WhatsApp"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_top" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>
<div class="td-post-content tagdiv-type">
<div class="td-post-featured-image"><a href="https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png" data-caption=""><img width="696" height="348" class="entry-thumb td-modal-image" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20696%20348'%3E%3C/svg%3E" data-lazy-srcset="https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-696x348.png 696w, https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-300x150.png 300w, https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-768x384.png 768w, https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-150x75.png 150w, https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png 800w" data-lazy-sizes="(max-width: 696px) 100vw, 696px" alt="Henry Cavill Will Reprise His Role As Superman In Man Of Steel 2" title="Henry Cavill Will Reprise His Role As Superman In Man Of Steel 2" data-lazy-src="https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-696x348.png" /><noscript><img width="696" height="348" class="entry-thumb td-modal-image" src="https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-696x348.png" srcset="https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-696x348.png 696w, https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-300x150.png 300w, https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-768x384.png 768w, https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2-150x75.png 150w, https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png 800w" sizes="(max-width: 696px) 100vw, 696px" alt="Henry Cavill Will Reprise His Role As Superman In Man Of Steel 2" title="Henry Cavill Will Reprise His Role As Superman In Man Of Steel 2"/></noscript></a></div>
<div class="td-a-rec td-a-rec-id-content_top  tdi_1 td_block_template_1">
<style>
/* custom css */
.tdi_1.td-a-rec{
					text-align: center;
				}.tdi_1 .td-element-style{
					z-index: -1;
				}.tdi_1.td-a-rec-img{
				    text-align: left;
				}.tdi_1.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }@media (max-width: 767px) {
				    .tdi_1.td-a-rec-img {
				        text-align: center;
				    }
                }
</style><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-5923199195091205" data-ad-slot="2806339856" data-auto-format="rspv" data-full-width="">
<div overflow=""></div>
</amp-ad></div><div class='code-block code-block-1' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5923199195091205" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5923199195091205" data-ad-slot="4538445030" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>Superman is one of the favorite characters of millions of people all over the globe. In 2013, Man of Steel was released based on this amazing character and won so many hearts. The film came under the banner of Warner Bros, with co-producers being Syncopy and Legendary Pictures. The viewers appreciated the performance of Henry Cavill a lot in that 2013 movie. </p>
<h2><strong>Man Of Steel 2 Release Date, Cast, Plot, Trailer</strong></h2>
<p>To date, people are waiting for a sequel to come for this Spiderman movie. However, there was no news from the production team about whether they were planning for a sequel or not. Finally, you will get a lovely movie to watch in the coming days. </p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5923199195091205" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5923199195091205" data-ad-slot="6857486619" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<div class="wp-block-image"><figure class="aligncenter size-full"><img width="800" height="400" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20800%20400'%3E%3C/svg%3E" alt="Man Of Steel 2 Release Date, Cast, Plot, Trailer" class="wp-image-141454" data-lazy-srcset="https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot.png 800w, https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot-300x150.png 300w, https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot-768x384.png 768w, https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot-150x75.png 150w, https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot-696x348.png 696w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot.png" /><noscript><img width="800" height="400" src="https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot.png" alt="Man Of Steel 2 Release Date, Cast, Plot, Trailer" class="wp-image-141454" srcset="https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot.png 800w, https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot-300x150.png 300w, https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot-768x384.png 768w, https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot-150x75.png 150w, https://alphanewscall.com/wp-content/uploads/2022/05/Man-Of-Steel-2-Release-Date-Cast-Plot-696x348.png 696w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></figure></div>
<p>As per the resources, Man of Steel 2 is going to hit the theaters soon. Although nothing has been revealed about the cast and crew, you can expect a high-voltage scenario in this part.<br>For further details, please check out this article and find out the release date of this interesting plot. </p>
<h2><strong>Man Of Steel 2 Storyline</strong></h2>
<p>Man of Steel 2 will definitely come with a bang and give lots of happiness to the viewers. But no one knows what the actual storyline is. You can only wait patiently for the upcoming film and predict that the performances of the actors will keep you engrossed this time also. </p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5923199195091205" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5923199195091205" data-ad-slot="6857486619" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>We will make an effort to let you know some important information in this regard. The plot may begin from the string the first Season left. However, the new movie doesn&#8217;t need to be a continuation of the old plot. A fresh story can also come to impress you in a different tone. Hence, only time can give the answer, which will be the actual story for the new movie. </p>
<h2><strong>Release Date Of Man Of Steel 2</strong></h2>
<p>According to the makers, the DC Comics superhero film will entertain you in 2022. Furthermore, the probable release date is somewhere in November. But nothing has been finalized, so the fans have to hold their breath until the final announcement. This time, you can find Zack Synder in the role of the director. </p>
<p>In the previous film, people got connected with <a href="https://en.wikipedia.org/wiki/Henry_Cavill" target="_blank" rel="noreferrer noopener">Henry Cavill,</a> and so the fans of the superhero only wanted him to play the character of Superman. But the actor has not shared any ultimate news in this respect. When asked about his comeback as Superman, Cavill replied that he would be more than happy to be part of this fantastic movie. </p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5923199195091205" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5923199195091205" data-ad-slot="6857486619" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>Moreover, he still feels that a lot is there to explore in the character of Superman. In his words, the closet always remains the ideal place for the cape. Hence, several opportunities are still left to come for Cavill to play Superman and connect with the different traits of the character.<br>After the interview, it became more confusing for the audience to predict whether they could watch Henry in this movie or not. </p>
<p>A large section of the viewers wants to see only Henry and no one else as Superman. They say that it will not be easy to accept any other actor in the sequel movie of Man of Steel. But, the cast, of course, is not in the hands of the actors. </p>
<p>After the declaration of the movie, social media is full of various requests to bring back Henry Cavill as Superman. Let us now see whether the makers agree to this request and think accordingly. </p><div class='code-block code-block-3' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5923199195091205" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5923199195091205" data-ad-slot="6857486619" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p>You can easily predict by now that the movie&#8217;s shooting has already started by now and is going to end soon. Only the final release date is yet to be announced. </p>
<h2><strong>Man Of Steel 2 Trailer</strong></h2>
<figure class="wp-block-embed aligncenter is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="Man of Steel - Official Trailer #2 [HD]" width="696" height="392" src="https://www.youtube.com/embed/KVu3gS7iJu4?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div></figure>
<p>The official trailer of Man of Steel is already there. So, you can get a glimpse of the marvelous charters from this short video. Hopefully, this time also, the sequel will be streaming on HBO Max. So, if you plan to catch the awesome film online, the chances are very high. </p>
<p>Apart from the hero, the most talked-about character of any show is its villain. We can also predict Brainiac to be the main villain of this movie, as you can see in most Superman comics. </p>
<p>The action movie will be packed with multiple intriguing sequences that will not let you blink. Keep waiting, and the movie will hit the big screens pretty soon.</p><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-5923199195091205" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-5923199195091205" data-ad-slot="4175482950" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<h2><strong>Cancellation Of The Sequel</strong></h2>
<p>This made the makers think once again about releasing a Superman movie in such a scenario. The apprehensions and doubts led to the wait for so many years. </p>
<p>Several questions are already arising about why the producers took such a long time to bring the Part 2 of Man of Steel. However, if you get back to 2017, you will find that there was an announcement to launch this movie in that year only. But, unfortunately, Batman Vs. Superman failed to become a block office hit in 2017. </p>
<p><strong>READ MORE:</strong></p>
<ul><li><a href="https://alphanewscall.com/2022/05/20/is-johnny-depp-dating-his-attorney/" target="_blank" rel="noreferrer noopener">Is Johnny Depp dating his Attorney? Know About Camille Vasquez!</a></li><li><a href="https://alphanewscall.com/2022/05/21/j-cole-net-worth/" target="_blank" rel="noreferrer noopener">J Cole’s Net Worth 2022: How Much Does He Make A Year?</a></li><li><a href="https://alphanewscall.com/2022/05/21/bad-bunny-net-worth/" target="_blank" rel="noreferrer noopener">What is bad bunnies&#8217; net worth? How much money does Bad Bunny make per show?</a></li></ul>

</div>
<footer>
 
<div class="td-post-source-tags">
 <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://alphanewscall.com/tag/movie/">movie</a></li><li><a href="https://alphanewscall.com/tag/top-trending/">Top Trending</a></li></ul> </div>
<div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://alphanewscall.com/2022/05/24/man-steel-2-release/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Falphanewscall.com%2F2022%2F05%2F24%2Fman-steel-2-release%2F" title="Facebook"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Man+Of+Steel+2+Release+Date%3A+Henry+Cavill+Will+Reprise+His+Role+As+Superman&url=https%3A%2F%2Falphanewscall.com%2F2022%2F05%2F24%2Fman-steel-2-release%2F&via=AlphaNewsCall" title="Twitter"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://alphanewscall.com/2022/05/24/man-steel-2-release/&amp;media=https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png&description=The DC Comics superhero film will entertain you in 2022. Furthermore, the probable release date is somewhere in November." title="Pinterest"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Man+Of+Steel+2+Release+Date%3A+Henry+Cavill+Will+Reprise+His+Role+As+Superman %0A%0A https://alphanewscall.com/2022/05/24/man-steel-2-release/" title="WhatsApp"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div> <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://alphanewscall.com/2022/05/24/lincoln-lawyer-season-2/">How The Lincoln Lawyer Is Set Up For Season 2 And Beyond? The Lincoln Lawyer Season 2 Renewal, Release Date, Cast, And More Updates!!</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://alphanewscall.com/2022/05/24/noah-thompson-wins-american-idol-2022-did-the-people-decide-correctly-more-details/">Noah Thompson wins &#8216;American Idol&#8217; 2022: Did The People Decide Correctly? More Details!!</a></div></div></div> <div class="author-box-wrap"><a href="https://alphanewscall.com/author/alphanewscallauthor/" aria-label="author-photo"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2096%2096'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/7ceaf5b124e5c46d90bb283eb64c0f95?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' data-lazy-src="https://secure.gravatar.com/avatar/7ceaf5b124e5c46d90bb283eb64c0f95?s=96&#038;d=mm&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/7ceaf5b124e5c46d90bb283eb64c0f95?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/7ceaf5b124e5c46d90bb283eb64c0f95?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript></a><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="https://alphanewscall.com/author/alphanewscallauthor/">AlphaNewscallAuthor</a></span></div><div class="td-author-description"></div><div class="td-author-social"></div><div class="clearfix"></div></div></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="AlphaNewscallAuthor"><meta itemprop="url" content="https://alphanewscall.com/author/alphanewscallauthor/"></span><meta itemprop="datePublished" content="2022-05-24T10:14:06+00:00"><meta itemprop="dateModified" content="2022-05-24T10:16:33+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://alphanewscall.com/2022/05/24/man-steel-2-release/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://alphanewscall.com/wp-content/uploads/2021/08/Alpha-News-Call-4-300x75.png"></span><meta itemprop="name" content="AlphaNewsCall"></span><meta itemprop="headline " content="Man Of Steel 2 Release Date: Henry Cavill Will Reprise His Role As Superman"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://alphanewscall.com/wp-content/uploads/2022/05/Henry-Cavill-Will-Reprise-His-Role-As-Superman-In-Man-Of-Steel-2.png"><meta itemprop="width" content="800"><meta itemprop="height" content="400"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts tdi_3 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_3"><script>var block_tdi_3 = new tdBlock();
block_tdi_3.id = "tdi_3";
block_tdi_3.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_3","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":141432,"live_filter_cur_post_author":"2","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_3","tdc_css_class_style":"tdi_3_rand_style"}';
block_tdi_3.td_column_number = "3";
block_tdi_3.block_type = "td_block_related_posts";
block_tdi_3.post_count = "3";
block_tdi_3.found_posts = "1121";
block_tdi_3.header_color = "";
block_tdi_3.ajax_pagination_infinite_stop = "";
block_tdi_3.max_num_pages = "374";
tdBlocksArray.push(block_tdi_3);
</script><h4 class="td-related-title td-block-title"><a id="tdi_4" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_3" href="#">RELATED ARTICLES</a><a id="tdi_5" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_3" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_3 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://alphanewscall.com/2022/05/24/aishwarya-rai-bachchan-cannes-festival-2005/" rel="nofollow bookmark" class="td-image-wrap " title="Aishwarya Rai Bachchan Became The First Indian Ever To Open The Cannes Film Festival In 2005"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" alt="Aishwarya Rai Bachchan Became The First Indian Ever To Open The Cannes Film Festival In 2005" title="Aishwarya Rai Bachchan Became The First Indian Ever To Open The Cannes Film Festival In 2005" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/05/Aishwarya-Rai-Bachchan-Became-The-First-Indian-Ever-To-Open-The-Cannes-Film-Festival-In-2005-218x150.jpg" width="218" height="150" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="Aishwarya Rai Bachchan Became The First Indian Ever To Open The Cannes Film Festival In 2005" title="Aishwarya Rai Bachchan Became The First Indian Ever To Open The Cannes Film Festival In 2005" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/05/Aishwarya-Rai-Bachchan-Became-The-First-Indian-Ever-To-Open-The-Cannes-Film-Festival-In-2005-218x150.jpg"  width="218" height="150" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://alphanewscall.com/2022/05/24/aishwarya-rai-bachchan-cannes-festival-2005/" rel="bookmark" title="Aishwarya Rai Bachchan Became The First Indian Ever To Open The Cannes Film Festival In 2005">Aishwarya Rai Bachchan Became The First Indian Ever To Open The Cannes Film Festival In 2005</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://alphanewscall.com/2022/05/20/station-19-season-6/" rel="nofollow bookmark" class="td-image-wrap " title="Will there be a Season 6 of Station 19? Is It Confirmed?"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" alt="" title="Will there be a Season 6 of Station 19? Is It Confirmed?" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/05/station-19-season-6-218x150.jpg" width="218" height="150" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Will there be a Season 6 of Station 19? Is It Confirmed?" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/05/station-19-season-6-218x150.jpg"  width="218" height="150" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://alphanewscall.com/2022/05/20/station-19-season-6/" rel="bookmark" title="Will there be a Season 6 of Station 19? Is It Confirmed?">Will there be a Season 6 of Station 19? Is It Confirmed?</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://alphanewscall.com/2022/05/20/made-for-love-season-3/" rel="nofollow bookmark" class="td-image-wrap " title="Made for Love season 3: Is it renewed or canceled at HBO Max? Latest Update!"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20218%20150'%3E%3C/svg%3E" alt="" title="Made for Love season 3: Is it renewed or canceled at HBO Max? Latest Update!" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/05/made-for-love-season-3-218x150.jpg" width="218" height="150" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Made for Love season 3: Is it renewed or canceled at HBO Max? Latest Update!" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/05/made-for-love-season-3-218x150.jpg"  width="218" height="150" /></noscript></a></div> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://alphanewscall.com/2022/05/20/made-for-love-season-3/" rel="bookmark" title="Made for Love season 3: Is it renewed or canceled at HBO Max? Latest Update!">Made for Love season 3: Is it renewed or canceled at HBO Max? Latest Update!</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_3" data-td_block_id="tdi_3"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_3" data-td_block_id="tdi_3"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2022/05/24/man-steel-2-release/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://alphanewscall.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
<div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div><div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='141432' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p></form> </div>
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">

</div>
</div>
</div> 
</div> 
</div> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span12">
</div>
</div>
<div class="td-pb-row">
<div class="td-pb-span4">
<div class="td_block_wrap td_block_7 tdi_7 td-pb-border-top td_block_template_1 td-column-1 td_block_padding" data-td-block-uid="tdi_7"><script>var block_tdi_7 = new tdBlock();
block_tdi_7.id = "tdi_7";
block_tdi_7.atts = '{"custom_title":"EDITOR PICKS","limit":3,"sort":"featured","block_type":"td_block_7","separator":"","custom_url":"","block_template_id":"","m6_tl":"","post_ids":"-141432","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","offset":"","show_modified_date":"","time_ago":"","time_ago_add_txt":"ago","time_ago_txt_pos":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","class":"tdi_7","tdc_css_class":"tdi_7","tdc_css_class_style":"tdi_7_rand_style"}';
block_tdi_7.td_column_number = "1";
block_tdi_7.block_type = "td_block_7";
block_tdi_7.post_count = "2";
block_tdi_7.found_posts = "2";
block_tdi_7.header_color = "";
block_tdi_7.ajax_pagination_infinite_stop = "";
block_tdi_7.max_num_pages = "1";
tdBlocksArray.push(block_tdi_7);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">EDITOR PICKS</span></h4></div><div id=tdi_7 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://alphanewscall.com/2022/04/20/some-of-the-biggest-wins-in-online-casino-history/" rel="nofollow bookmark" class="td-image-wrap " title="Some Of The Biggest Wins In Online Casino History"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" alt="Some Of The Biggest Wins In Online Casino History" title="Some Of The Biggest Wins In Online Casino History" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/04/Some-Of-The-Biggest-Wins-In-Online-Casino-History-100x70.jpeg" width="100" height="70" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="Some Of The Biggest Wins In Online Casino History" title="Some Of The Biggest Wins In Online Casino History" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/04/Some-Of-The-Biggest-Wins-In-Online-Casino-History-100x70.jpeg"  width="100" height="70" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://alphanewscall.com/2022/04/20/some-of-the-biggest-wins-in-online-casino-history/" rel="bookmark" title="Some Of The Biggest Wins In Online Casino History">Some Of The Biggest Wins In Online Casino History</a></h3> <div class="td-module-meta-info">
 <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-04-20T15:54:49+00:00">April 20, 2022</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://alphanewscall.com/2022/03/13/a-wonderful-3-nights-4-days-trip-to-maldives/" rel="nofollow bookmark" class="td-image-wrap " title="A Wonderful 3 Nights 4 Days Trip to Maldives"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" alt="A Wonderful 3 Nights 4 Days Trip to Maldives" title="A Wonderful 3 Nights 4 Days Trip to Maldives" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/03/word-image-4-100x70.jpeg" width="100" height="70" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="A Wonderful 3 Nights 4 Days Trip to Maldives" title="A Wonderful 3 Nights 4 Days Trip to Maldives" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/03/word-image-4-100x70.jpeg"  width="100" height="70" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://alphanewscall.com/2022/03/13/a-wonderful-3-nights-4-days-trip-to-maldives/" rel="bookmark" title="A Wonderful 3 Nights 4 Days Trip to Maldives">A Wonderful 3 Nights 4 Days Trip to Maldives</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-03-12T19:55:08+00:00">March 13, 2022</time></span> </div>
</div>
</div>
</div> </div></div>  </div>
<div class="td-pb-span4">
<div class="td_block_wrap td_block_7 tdi_8 td-pb-border-top td_block_template_1 td-column-1 td_block_padding" data-td-block-uid="tdi_8"><script>var block_tdi_8 = new tdBlock();
block_tdi_8.id = "tdi_8";
block_tdi_8.atts = '{"custom_title":"POPULAR POSTS","limit":3,"sort":"popular","block_type":"td_block_7","separator":"","custom_url":"","block_template_id":"","m6_tl":"","post_ids":"-141432","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","offset":"","show_modified_date":"","time_ago":"","time_ago_add_txt":"ago","time_ago_txt_pos":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","class":"tdi_8","tdc_css_class":"tdi_8","tdc_css_class_style":"tdi_8_rand_style"}';
block_tdi_8.td_column_number = "1";
block_tdi_8.block_type = "td_block_7";
block_tdi_8.post_count = "3";
block_tdi_8.found_posts = "2336";
block_tdi_8.header_color = "";
block_tdi_8.ajax_pagination_infinite_stop = "";
block_tdi_8.max_num_pages = "779";
tdBlocksArray.push(block_tdi_8);
</script><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">POPULAR POSTS</span></h4></div><div id=tdi_8 class="td_block_inner">
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://alphanewscall.com/2021/11/01/the-royals-season-5/" rel="nofollow bookmark" class="td-image-wrap " title="The Royals Season 5 Release Date | Cast | Plot | Trailer And More"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" alt="The Royals season 5" title="The Royals Season 5 Release Date | Cast | Plot | Trailer And More" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2021/10/The-Royals-season-5-100x70.jpg" width="100" height="70" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="The Royals season 5" title="The Royals Season 5 Release Date | Cast | Plot | Trailer And More" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2021/10/The-Royals-season-5-100x70.jpg"  width="100" height="70" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://alphanewscall.com/2021/11/01/the-royals-season-5/" rel="bookmark" title="The Royals Season 5 Release Date | Cast | Plot | Trailer And More">The Royals Season 5 Release Date | Cast | Plot |...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2021-11-01T07:30:41+00:00">November 1, 2021</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://alphanewscall.com/2022/05/04/father-amber-heards-daughter/" rel="nofollow bookmark" class="td-image-wrap " title="Revealed!!! Who Is The Father Of Amber Heard’s Daughter? When Did She Welcome Her Daughter?"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" alt="" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/plugins/td-standard-pack/Newspaper/assets/images/no-thumb/td_100x70.png" width="100" height="70" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/plugins/td-standard-pack/Newspaper/assets/images/no-thumb/td_100x70.png"  width="100" height="70" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://alphanewscall.com/2022/05/04/father-amber-heards-daughter/" rel="bookmark" title="Revealed!!! Who Is The Father Of Amber Heard’s Daughter? When Did She Welcome Her Daughter?">Revealed!!! Who Is The Father Of Amber Heard’s Daughter? When Did...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-05-03T20:40:34+00:00">May 4, 2022</time></span> </div>
</div>
</div>
</div> 
<div class="td-block-span12">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://alphanewscall.com/2022/03/02/tay-k-release-date/" rel="nofollow bookmark" class="td-image-wrap " title="Tay K Release Date: When Will Your Popular American rapper Be Out Of Prison?"><img class="entry-thumb" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%2070'%3E%3C/svg%3E" alt="" title="Tay K Release Date: When Will Your Popular American rapper Be Out Of Prison?" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/03/Tay-K-release-date-100x70.jpg" width="100" height="70" data-lazy-src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" /><noscript><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII=" alt="" title="Tay K Release Date: When Will Your Popular American rapper Be Out Of Prison?" data-type="image_tag" data-img-url="https://alphanewscall.com/wp-content/uploads/2022/03/Tay-K-release-date-100x70.jpg"  width="100" height="70" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://alphanewscall.com/2022/03/02/tay-k-release-date/" rel="bookmark" title="Tay K Release Date: When Will Your Popular American rapper Be Out Of Prison?">Tay K Release Date: When Will Your Popular American rapper Be...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-03-02T17:50:27+00:00">March 2, 2022</time></span> </div>
</div>
</div>
</div> </div></div>  </div>
<div class="td-pb-span4">
<div class="td_block_wrap td_block_popular_categories tdi_9 widget widget_categories td-pb-border-top td_block_template_1" data-td-block-uid="tdi_9">
<style>
/* custom css */
.td_block_popular_categories{
                  padding-bottom: 0;
                }
</style><div class="td-block-title-wrap"><h4 class="block-title td-block-title"><span class="td-pulldown-size">POPULAR CATEGORY</span></h4></div><ul class="td-pb-padding-side"><li><a href="https://alphanewscall.com/category/entertainment/"><span class="td-cat-name">Entertainment</span><span class="td-cat-no">1122</span></a></li><li><a href="https://alphanewscall.com/category/news/"><span class="td-cat-name">News</span><span class="td-cat-no">453</span></a></li><li><a href="https://alphanewscall.com/category/india/"><span class="td-cat-name">India</span><span class="td-cat-no">261</span></a></li><li><a href="https://alphanewscall.com/category/celebrity/"><span class="td-cat-name">celebrity</span><span class="td-cat-no">256</span></a></li><li><a href="https://alphanewscall.com/category/top-stories/"><span class="td-cat-name">Top Stories</span><span class="td-cat-no">249</span></a></li><li><a href="https://alphanewscall.com/category/reviews/"><span class="td-cat-name">Reviews</span><span class="td-cat-no">160</span></a></li><li><a href="https://alphanewscall.com/category/trending/"><span class="td-cat-name">Trending</span><span class="td-cat-no">157</span></a></li><li><a href="https://alphanewscall.com/category/feature/"><span class="td-cat-name">Feature</span><span class="td-cat-no">149</span></a></li><li><a href="https://alphanewscall.com/category/world/"><span class="td-cat-name">World</span><span class="td-cat-no">110</span></a></li></ul></div> </div>
</div>
</div>
<div class="td-footer-bottom-full">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://alphanewscall.com/"><img width="300" height="75" class="td-retina-data" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%2075'%3E%3C/svg%3E" data-retina="https://alphanewscall.com/wp-content/uploads/2021/08/cropped-Alpha-News-Call-Icon-300x300.png" alt="" title="" data-lazy-src="https://alphanewscall.com/wp-content/uploads/2021/08/Alpha-News-Call-4-300x75.png" /><noscript><img width="300" height="75" class="td-retina-data" src="https://alphanewscall.com/wp-content/uploads/2021/08/Alpha-News-Call-4-300x75.png" data-retina="https://alphanewscall.com/wp-content/uploads/2021/08/cropped-Alpha-News-Call-Icon-300x300.png" alt="" title=""   /></noscript></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div></aside></div> </div>
</div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
</div>
<div class="td-pb-span td-sub-footer-copy">
&copy; </div>
</div>
</div>
</div>
</div>
</div>

<div id="amp-mobile-version-switcher" hidden>
<a rel="" href="https://alphanewscall.com/2022/05/24/man-steel-2-release/amp/">
Go to mobile version </a>
</div>
<script type='text/javascript' id='rocket-browser-checker-js-after'>
"use strict";var _createClass=function(){function defineProperties(target,props){for(var i=0;i<props.length;i++){var descriptor=props[i];descriptor.enumerable=descriptor.enumerable||!1,descriptor.configurable=!0,"value"in descriptor&&(descriptor.writable=!0),Object.defineProperty(target,descriptor.key,descriptor)}}return function(Constructor,protoProps,staticProps){return protoProps&&defineProperties(Constructor.prototype,protoProps),staticProps&&defineProperties(Constructor,staticProps),Constructor}}();function _classCallCheck(instance,Constructor){if(!(instance instanceof Constructor))throw new TypeError("Cannot call a class as a function")}var RocketBrowserCompatibilityChecker=function(){function RocketBrowserCompatibilityChecker(options){_classCallCheck(this,RocketBrowserCompatibilityChecker),this.passiveSupported=!1,this._checkPassiveOption(this),this.options=!!this.passiveSupported&&options}return _createClass(RocketBrowserCompatibilityChecker,[{key:"_checkPassiveOption",value:function(self){try{var options={get passive(){return!(self.passiveSupported=!0)}};window.addEventListener("test",null,options),window.removeEventListener("test",null,options)}catch(err){self.passiveSupported=!1}}},{key:"initRequestIdleCallback",value:function(){!1 in window&&(window.requestIdleCallback=function(cb){var start=Date.now();return setTimeout(function(){cb({didTimeout:!1,timeRemaining:function(){return Math.max(0,50-(Date.now()-start))}})},1)}),!1 in window&&(window.cancelIdleCallback=function(id){return clearTimeout(id)})}},{key:"isDataSaverModeOn",value:function(){return"connection"in navigator&&!0===navigator.connection.saveData}},{key:"supportsLinkPrefetch",value:function(){var elem=document.createElement("link");return elem.relList&&elem.relList.supports&&elem.relList.supports("prefetch")&&window.IntersectionObserver&&"isIntersecting"in IntersectionObserverEntry.prototype}},{key:"isSlowConnection",value:function(){return"connection"in navigator&&"effectiveType"in navigator.connection&&("2g"===navigator.connection.effectiveType||"slow-2g"===navigator.connection.effectiveType)}}]),RocketBrowserCompatibilityChecker}();
</script>
<script type='text/javascript' id='rocket-preload-links-js-extra'>
/* <![CDATA[ */
var RocketPreloadLinksConfig = {"excludeUris":"\/(?:.+\/)?feed(?:\/(?:.+\/?)?)?$|\/(?:.+\/)?embed\/|\/(index\\.php\/)?wp\\-json(\/.*|$)|\/wp-admin\/|\/logout\/|\/wp-login.php|\/refer\/|\/go\/|\/recommend\/|\/recommends\/","usesTrailingSlash":"1","imageExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php","fileExt":"jpg|jpeg|gif|png|tiff|bmp|webp|avif|pdf|doc|docx|xls|xlsx|php|html|htm","siteUrl":"https:\/\/alphanewscall.com","onHoverDelay":"100","rateThrottle":"3"};
/* ]]> */
</script>
<script type='text/javascript' id='rocket-preload-links-js-after'>
(function() {
"use strict";var r="function"==typeof Symbol&&"symbol"==typeof Symbol.iterator?function(e){return typeof e}:function(e){return e&&"function"==typeof Symbol&&e.constructor===Symbol&&e!==Symbol.prototype?"symbol":typeof e},e=function(){function i(e,t){for(var n=0;n<t.length;n++){var i=t[n];i.enumerable=i.enumerable||!1,i.configurable=!0,"value"in i&&(i.writable=!0),Object.defineProperty(e,i.key,i)}}return function(e,t,n){return t&&i(e.prototype,t),n&&i(e,n),e}}();function i(e,t){if(!(e instanceof t))throw new TypeError("Cannot call a class as a function")}var t=function(){function n(e,t){i(this,n),this.browser=e,this.config=t,this.options=this.browser.options,this.prefetched=new Set,this.eventTime=null,this.threshold=1111,this.numOnHover=0}return e(n,[{key:"init",value:function(){!this.browser.supportsLinkPrefetch()||this.browser.isDataSaverModeOn()||this.browser.isSlowConnection()||(this.regex={excludeUris:RegExp(this.config.excludeUris,"i"),images:RegExp(".("+this.config.imageExt+")$","i"),fileExt:RegExp(".("+this.config.fileExt+")$","i")},this._initListeners(this))}},{key:"_initListeners",value:function(e){-1<this.config.onHoverDelay&&document.addEventListener("mouseover",e.listener.bind(e),e.listenerOptions),document.addEventListener("mousedown",e.listener.bind(e),e.listenerOptions),document.addEventListener("touchstart",e.listener.bind(e),e.listenerOptions)}},{key:"listener",value:function(e){var t=e.target.closest("a"),n=this._prepareUrl(t);if(null!==n)switch(e.type){case"mousedown":case"touchstart":this._addPrefetchLink(n);break;case"mouseover":this._earlyPrefetch(t,n,"mouseout")}}},{key:"_earlyPrefetch",value:function(t,e,n){var i=this,r=setTimeout(function(){if(r=null,0===i.numOnHover)setTimeout(function(){return i.numOnHover=0},1e3);else if(i.numOnHover>i.config.rateThrottle)return;i.numOnHover++,i._addPrefetchLink(e)},this.config.onHoverDelay);t.addEventListener(n,function e(){t.removeEventListener(n,e,{passive:!0}),null!==r&&(clearTimeout(r),r=null)},{passive:!0})}},{key:"_addPrefetchLink",value:function(i){return this.prefetched.add(i.href),new Promise(function(e,t){var n=document.createElement("link");n.rel="prefetch",n.href=i.href,n.onload=e,n.onerror=t,document.head.appendChild(n)}).catch(function(){})}},{key:"_prepareUrl",value:function(e){if(null===e||"object"!==(void 0===e?"undefined":r(e))||!1 in e||-1===["http:","https:"].indexOf(e.protocol))return null;var t=e.href.substring(0,this.config.siteUrl.length),n=this._getPathname(e.href,t),i={original:e.href,protocol:e.protocol,origin:t,pathname:n,href:t+n};return this._isLinkOk(i)?i:null}},{key:"_getPathname",value:function(e,t){var n=t?e.substring(this.config.siteUrl.length):e;return n.startsWith("/")||(n="/"+n),this._shouldAddTrailingSlash(n)?n+"/":n}},{key:"_shouldAddTrailingSlash",value:function(e){return this.config.usesTrailingSlash&&!e.endsWith("/")&&!this.regex.fileExt.test(e)}},{key:"_isLinkOk",value:function(e){return null!==e&&"object"===(void 0===e?"undefined":r(e))&&(!this.prefetched.has(e.href)&&e.origin===this.config.siteUrl&&-1===e.href.indexOf("?")&&-1===e.href.indexOf("#")&&!this.regex.excludeUris.test(e.href)&&!this.regex.images.test(e.href))}}],[{key:"run",value:function(){"undefined"!=typeof RocketPreloadLinksConfig&&new n(new RocketBrowserCompatibilityChecker({capture:!0,passive:!0}),RocketPreloadLinksConfig).init()}}]),n}();t.run();
}());
</script>
<script type='text/javascript' id='tds_js_files_for_front-js-extra'>
/* <![CDATA[ */
var tds_js_globals = {"wpRestNonce":"8243eebc83","wpRestUrl":"https:\/\/alphanewscall.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
/* ]]> */
</script>

<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://alphanewscall.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
<script src="https://alphanewscall.com/wp-content/cache/min/1/19143fa7b6a56ca9d95958e07e124cd6.js" data-minify="1"></script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'710710591cb85734',m:'ZrtGMFEOilTo4Fv7WDsqSKxRh7UwXTNeQ2q9on5VQLw-1653406135-0-Aczz1mJ6qTSJr2ceXURsd4DuAL5z+PRc1b0Z21yYIm1icflwPgaeNGZLHX7pEq6d7btvFz153PKFetO6DQhwf9MhEG3uHRcLI2Gm8SHIBzAuD6UOa1GNckyqRC6YchltnWPDKguKfBR5Eg2G3Dkakddv6bIyG/icnf+VamEwa3IE',s:[0x974ae97098,0x0e5bf01dee],}})();</script></body>
</html>
